This is a list of reserved words — words you should not use in variable names, or as function names.
abstract	delete		InnerWidth	Packages	status
alert		do		Instaceof	pageXOffset	statusbar
arguments	document	int		pageYoffset	stop
Array		double		interface	parent		String
blur		else		isFinite	parseFloat	super
boolean		enum		isNaN		parseInt	switch
Boolean		escape		java		personalbar	synchronized
break		eval		length		print		this
byte		export		location	private		throw
callee		extends		locationbar	prompt		throws
caller		final		long		protected	toolbar
captureEvents	finally		Math		prototype	top
case		find		menubar		public		toString
catch		float		moveBy		RegExp		transient
char		focus		moveTo		releaseEvents	try
class		for		name		resizeBy	typeof
clearInterval	frames		NaN		resizeTo	unescape
clearTimeout	Function	native		return		unwatch
close		function	netscape	routeEvent	valueOf
closed		goto		new		scroll		var
confirm		history		null		scrollbars	void
const		home		Number		scrollBy	watch
constructor	if		Object		scrollTo	while
continue	implements	open		self		window
Date		import		opener		setInterval	with
debugger	in		outerHeight	setTimeout	FALSE
default		Infinity	OuterWidth	Short		TRUE
defaultStatus	innerHeight	package		static

Examples of better names are 'x' or 'myWin' or 'dataSent' or 'firstName' or 'last_name'. When in doubt, put a 'my' on the front and you can be sure it won't appear in the list of reserved words. Keep in mind that JavaScript is case sensitive. This means that 'firstName' and 'firstname' are two different variables.